Introduction to Bioinformatics online course: IBT

Multiple Sequence Alignment

Lec3: Navigation in Cursor mode

By

Ahmed Mansour Alzohairy
Professor (Full) at Department of Genetics, Zagazig University, Zagazig, Egypt
Points to remember
- Jalview primary function is the editing and visualization of sequence alignments, and their interactive analysis.
- Tree building, principal components analysis, physico-chemical property conservation and sequence consensus analyses.
- Web services enable Jalview to access remote alignment and secondary structure prediction programs, as well as to retrieve protein and nucleic acid sequences, alignments, protein structures and sequence annotation.
- Alignment views are *dynamically linked* with *Jmol* structure displays, a tree viewer and spatial cluster display, facilitating interactive exploration of the alignment’s structure.
- The application provides its own *Jalview project file format* in order to store the current state of an alignment and analysis windows.

- Jalview also provides **WYSIWIG7** style *figure generation capabilities* for the preparation of alignments for publication.
- Sequences, alignments, trees, structures, features and alignment annotation may also be exchanged with the local file system.

- Multiple visualizations of an alignment may be worked on simultaneously, and the user interface provides a comprehensive set of controls for coloring and layout.
Jalview Desktop, however, is much more powerful, and includes additional support for interaction with external web services, and production of publication quality graphics.
When Jalview starts it will automatically load an example alignment from the Jalview site. This behaviour can be changed in the Jalview Desktop preferences dialog opened from the Desktop’s Tools ⇒ Preferences ⇒ Open file menu.
Jalview News RSS Feed

From time to time, important announcements are made available to users of the Jalview Desktop via the Jalview News reader. This window will open automatically when new news is available, and can also be accessed via the Desktop’s Tools ⇒ Show Jalview News menu entry.
Getting Help

Jalview has comprehensive on-line help documentation. *Select Help ⇒ Documentation* from the main window menu and a new window will open. The appropriate topic can then be selected from the navigation panel on the left hand side. To search for a specific topic, click the ‘search’ tab and enter keywords in the box which appears.

![Figure 1.6: Accessing the built in Jalview documentation](image)
Email lists

The Jalview Discussion list jalview-discuss@jalview.org provides a forum for Jalview users and developers to raise problems and exchange ideas - any problems, bugs, and requests for help should be raised here. The jalview-announce@jalview.org list can also be subscribed to if you wish to be kept informed of new releases and developments.
confirm b957896723d644fb4b77e91ada406e15b66a78ab

From: "jalview-announce-request@compbio.dundee.ac.uk" <jalview-announce-request@compbio.dundee.ac.uk>
To: alzohairy@yahoo.com

Mailing list subscription confirmation notice for mailing list
Jalview-announce

We have received a request from 10.0.3.23 for subscription of your email address, "alzohairy@yahoo.com", to the jalview-announce@compbio.dundee.ac.uk mailing list. To confirm that you want to be added to this mailing list, simply reply to this message, keeping the Subject: header intact. Or visit this web page:

http://www.compbio.dundee.ac.uk/mailman/confirm/jalview-announce/b957896723d644fb4b77e91ada406e15b66a78ab

Or include the following line -- and only the following line -- in a message to jalview-announce-request@compbio.dundee.ac.uk:

confirm b957896723d644fb4b77e91ada406e15b66a78ab

Note that simply sending a 'reply' to this message should work from most mail readers, since that usually leaves the Subject: line in the right form (additional "Re:" text in the Subject: is okay).

If you do not wish to be subscribed to this list, please simply disregard this message. If you think you are being maliciously subscribed to the list, or have any other questions, send them to jalview-announce-owner@compbio.dundee.ac.uk.
Loading your own sequence
Jalview provides many ways to load - your own sequences.
- Drag and Drop
- From a File
- From a URL
- Cut and Paste
- From a public database
Drag and Drop

- In most operating systems you can just drag a file icon *from a file browser window* and drop it on an open Jalview application window.
- Drag and drop also *works* when loading data *from a URL* - simply drag the *link or URL* from the address panel of your browser on to an alignment or the Jalview desktop background and Jalview will load data from the URL directly.
From a File

Jalview can read sequence alignments from a sequence alignment file. This is a text file, NOT a word processor document.

Select **File ⇒ Input Alignment ⇒ From File** from the main menu. Remember to select the appropriate file type. Jalview can automatically identify some sequence file formats.
From a URL

Jalview can read sequence alignments directly from a URL. Please note that the files must be in a sequence alignment format - an HTML alignment or graphics file cannot be read by Jalview.

Select **File ⇒ Input Alignment ⇒ From URL**

Jalview will attempt to automatically discover the file format.
Cut and Paste

- Documents such as those produced by Microsoft Word cannot be readily understood by Jalview. The way to read sequences from these documents is to select the data from the document and copy it to the clipboard. There are two ways to do this:

  1- One is to right-click on the desktop background, and select the ‘Paste to new alignment’ option in the menu that appears.

  2- The other is to select **File ⇒ Input Alignment ⇒ From Textbox** from the main menu, and paste the sequences into the textbox window that will appear. In both cases, sequences should be in the right format.
From a public database

- Jalview can retrieve sequences and sequence alignments from the public databases housed at the European Bioinformatics Institute, including Uniprot, Pfam, Rfam and the PDB, as well as any DAS sequence server registered at the configured DAS registry.
- Jalview’s sequence fetching capabilities allow you to avoid having to manually locate and save sequences from a web page before loading them into Jalview. It also allows Jalview to gather additional metadata provided by the source, such as annotation and database cross references. **Select File ⇒ Fetch Sequence(s)**
Pressing the database selection button in the dialog box opens a new window showing all the database sources Jalview can access (grouped by the type of database).

Once you’ve selected the appropriate database, hit (OK) close the database selection window, and then enter one or several database IDs or accession numbers separated by a semicolon and press (OK). (Jalview) will then attempt to retrieve them from the chosen database.
Exercise:

“To try on your own time”

Loading sequences.

- Start Jalview then close all windows (if necessary) by selecting Window ⇒ Close All from the Desktop window.
- Select File ⇒ Input Alignment ⇒ From URL from the Desktop and enter http://www.jalview.org/tutorial/alignment.fa in the box. Click OK and the alignment should load.
- Close all windows using the Window ⇒ Close All menu option from the Desktop. Point your web browser at the same URL (http://www.jalview.org/tutorial/alignment.fa) and save the file to your desktop.
- Open this file in Jalview by selecting File ⇒ Input Alignment ⇒ From File from the main menu and selecting the file from your desktop. Click OK and load the alignment.
- Select Desktop ⇒ Window ⇒ Close All and drag the alignment.fa file from the desktop onto the Jalview window. The alignment should open. Try dragging onto an empty Jalview and onto an existing alignment and observe the results. You can also try dragging the URL directly onto Jalview.
Exercise: Continue
To try on your own time

- Select File ⇒ Fetch Sequence(s). from the Desktop. Select the PFAM seed database and enter the accession number PF03460. Click OK. An alignment of about 107 sequences should load.
- Open http://www.jalview.org/tutorial/alignment.fa in a web browser. Note: If the URL is downloaded instead of opened in the browser, then locate the file in your download directory and open it in a text editor.
- Select and copy the entire text to the clipboard (usually via the browser’s Edit ⇒ Copy menu option).
- Ensure Jalview is running and select File ⇒ Input Alignment ⇒ From Textbox.
- Paste the clipboard into the large window using the Edit ⇒ Paste text box menu option. Click New Window and the alignment will be loaded.
Navigation

The major features of the Jalview Desktop are illustrated in Figure. The alignment window is the primary window for editing and visualization, and can contain several independent views of the alignment being worked with. The other windows (Trees, Structures, PCA plots, etc) are linked to a specific alignment view. Each area of the alignment window has a separate context menu accessed by clicking the right mouse button.
Navigation
Jalview has two navigation and editing modes: 
1- **Normal mode**, where editing and navigation is performed using the mouse, 
2- **Cursor mode** where editing and navigation are performed using the keyboard. 

The **F2 key** is used to switch between these two modes.
Navigation in Normal mode

- Jalview always starts up in Normal mode, where the mouse is used to interact with the displayed alignment view.
- You can move about the alignment by clicking and dragging the ruler scroll bar to move horizontally, or by clicking and dragging the alignment scroll bar to the right of the alignment to move vertically.

- If all the rows or columns in the alignment are displayed, the scroll bars will not be visible.
Each alignment view shown in the alignment window presents a window onto the visible regions of the alignment. This means that with anything more than a few residues or sequences, alignments can become difficult to visualize on the screen because only a small area can be shown at a time. It can help, especially when examining a large alignment, to have an overview of the whole alignment.

**Select View ⇒ Overview Window**
from the Alignment window menu bar.
- The red box in the overview window shows the current view in the alignment window.
- A percent identity histogram is plotted below the alignment overview.
- Shaded parts indicate rows and columns of the alignment that are hidden (in this case, a single row at the bottom of the alignment).
- You can navigate around the alignment by dragging the red box.
Close windows

Alignment and analysis windows are closed by clicking on the usual ‘close’ icon (indicated by arrows on Mac OS X). If you want to close all the alignments and analysis windows at once, then use the Window ⇒ Close All

Warning: make sure you have saved your work because this cannot be undone!
Navigation in Cursor mode

- **Cursor mode** navigation enables the experienced user to quickly and precisely **navigate, select and edit** parts of an alignment.
- On pressing **F2** to enter **cursor mode** the position of the cursor is indicated by a black background and white text.
- The **cursor** can be placed using the **mouse** or moved by pressing the arrow keys (↑, ↓, ←, →).
Rapid movement to specific positions is accomplished as listed below:

- **Jump to Sequence n**: Type a number n then press [S] to move to sequence **(row)** n

- **Jump to Column n**: Type a number n then press [C] to move to **column** n in the alignment.

- **Jump to Residue n**: Type a number n then press [P] to move to **residue number** n in the current sequence.

- **Jump to column m row n**: Type the **column number** m, a comma, the **row number** n and press [RETURN].
The Find Dialog Box

A further option for navigation is to use the **Select ⇒ Find... function**.

- This opens a dialog box into which can be entered regular expressions for searching sequences and sequence IDs, or sequence numbers.
- Hitting the [Find next] button will highlight the first (or next) occurrence of that pattern in the sequence ID panel or the alignment, and will adjust the view in order to display the highlighted region.
Exercise: Navigation
“To try on your own time”

1- Reload the example file by accessing the Desktop’s
   File ⇒ Input Alignment ⇒ From URL dialog and clicking on the down arrow to retrieve the example file
   URL stored in its history (http://www.jalview.org/examples/exampleFile_2_7.jar)

2- Scroll around the alignment using the alignment (vertical) and ruler (horizontal) scroll bars.

3- Find and open the Overview Window. Move around the alignment by clicking and dragging the red
   box in the overview window.

4 Look at the status bar as you move the mouse over the alignment. It should indicate information
   about the sequence and residue under the cursor.

5- Press [F2] to enter Cursor mode. Use the arrow keys to move the cursor around the alignment.
   - Move to sequence 7 by pressing 7S.
   - Move to column 18 by pressing 18C.
   - Move to residue 18 by pressing 18P.
   - Move to sequence 5, column 13 by typing 13, 5 [RETURN]
   Note that these can be two different positions if gaps are inserted into the sequence.
Introduction to Bioinformatics Online Course: IBT
Multiple Sequence Alignment | Prof. Ahmed M. Alzohairy
By

Ahmed Mansour Alzohairy
Department of Genetics, Zagazig University, Zagazig, Egypt