Software Requirements (DM)

For those of you which want to work with your own laptops, We will ask you to please download AnalyseSI 0.75.jar available from this url:

https://launchpad.net/analysesi
and please download and install MySQLWorkbench available from this url:

http://dev.mysql.com/downloads/tools/workbench/
than select the version which is appropriate to your platform/Operating system.

In order to interact with database using MySQL queries (via Mysql-client and PhpMyadmin), We will ask you to please install mysql-server, mysql-client, apache2, PHP5 and its MySQL Support and phpMyAdmin on your machines.
Please refer to these urls:

http://www.howtoforge.com/installing-apache2-with-php5-and-mysql-support-on-ubuntu-13.04-lamp if you are using Linux (ubuntu) OS

http://lowagie.com/wamp-install if you are using Windows OS

 

To interact with a mySQL database using python, you need to install some packages. To do this, type:

sudo apt-get install python-mysqldb
sudo apt-get install build-essential python-dev libmysqlclient-dev

Download MySQL-python-1.2.3.tar.gz

Decompress the folder using “tar -xzvf MySQL-python-1.2.3.tar.gz”, then type “cd MySQL-python-1.2.3”

Then type: python setup.py build
python setup.py install

Please let us know if you encounter problems to install these softwares on your machines, and we will guide you throw the different steps.

Leave a Reply